Android devices

The ShockWiz App is compatible with most Android devices that feature Bluetooth Low Energy (also called Bluetooth Smart and Bluetooth 4.0). The App requires at minimum Android version 4.3 (Jelly Bean). 

Check your device's manufacturer specifications to determine it's Bluetooth functionality and minimum supported OS version.

It is highly recommended that you use newer phones running the latest Android OS. Older, less powerful phones will struggle with performance.We are actively working on improving the performance for all devices.

Known Android Issues

  • If ShockWiz is connected to your phone will not connect to the ShockWiz App, see this article here.
  • Bluetooth cache if full - If you are having difficulty connecting ShockWiz to the ShockWiz app turn your phone off and then back on to clear the Bluetooth cache.
  • Disable WiFi or WiFi hotspot while using the ShockWiz app if you are experiencing connection issues.